Feeds:
Entradas
Comentarios

Adobe Flash Player en Firefox / Iceweasel AMD 64 bits

Actualizado el día 24-Junio-2008

Bueno, ahora que llega el verano he instalado Debian Lenny y he instalado el dichoso Flash de la siguiente manera (mucho más fácil que la antigua y por cierto he usado paquetes de Ubuntu 8.04 ya que funcionaban bien aunque no he probado los de Debian, si es que hay) :

  1. Descargar Iceweasel/Firefox
  2. # apt-get install ia32-libs gsfonts-x11 nspluginwrapper
  3. Ir a aquí y bajar esto ( flashplugin-nonfree, Flash v9)
  4. Ahora instalamos flashplugin-nonfree así: # dpkg -i nombre_y_ruta_del_paquete_Flash_que_acabamos_de_bajar ya tendremos Flash, toca reiniciar el navegador.
  5. Id por ejemplo a Youtube y podréis ver videos y escuchar el sonido en arquitecturas de 64 bit.

##########

Este post fue redactado el día Dom, Vie, 05/18/2007 @ 15:29. A día de hoy quizás esté desfasado pero funciona.

This post was redacted some time ago so it’s perfectly possible that is little bit old fashioned but it works. (Instructions in English at the end)

Esto es un minimanual para poder hacer funcionar las animaciones en Flash u otros contenidos en las diversas páginas webs que podemos encontrar por Internet así como el archiconocido portal de videos, YouTube.

El método es simple, así a grandes rasgos sólo hay que bajar el Flash en su versión de 32 bits (creo que es la única que existe) y un programita compuesto de dos partes que se encargará de hacer funcionar Flash en nuestro navegador Firefox 64 bit o X86-64. No sé si funciona en Konqueror porque no lo he probado recientemente pero creo recordar que no funcionaba y daba fallos. Tampoco es un método para enjaular Firefox 32 bits, así que ahí vamos.

En castellano:

Primero deberemos bajar nspluginwrapper, que consta de dos paquetes (RPM):

  1. wget http://gwenole.beauchesne.info/projects/nspluginwrapper/files/nspluginwrapper-0.9.91.4-1.x86_64.rpm (Que es el Plugin)
  2. wget http://gwenole.beauchesne.info/projects/nspluginwrapper/files/nspluginwrapper-i386-0.9.91.4-1.x86_64.rpm (Que es el visualizador)

Si no funcionan los enlaces directos, id aquí.

Ahora descargamos la última versión de Flash v9 para Linux en 32 bits(sí has leído bien) desde aquí y descomprimimos, aunque sólo necesitamos un archivo, libflashplayer.so

# apt-get install ia32-libs ia32-libs-* alien linux32

Convertimos con alien a formato deb los archivos en RPM así:

# alien -d *.rpm

Y cuando estén “alienados” pues los instalamos con
# dpkg -i rutapaquete.deb

Movemos libflashplayer.so a /usr/lib/mozilla/plugins y hacemos lo siguiente:

# /usr/lib/nspluginwrapper/x86_64/linux/npconfig -i /usr/lib/mozilla/plugins/libflashplayer.so

ó

# nspluginwrapper -i /usr/lib/mozilla/plugins/libflashplayer.so

Y ya tendremos preparado IceWeasel64 con Flash en su versión de 32 bit hasta que haya una versión nativa.

———————

Now in english:

Firstly we have to download nspluginwrapper in RPM format (the viewer and the plugin), so:

  1. wget http://gwenole.beauchesne.info/projects/nspluginwrapper/files/nspluginwrapper-0.9.91.4-1.x86_64.rpm (Plugin)
  2. wget http://gwenole.beauchesne.info/projects/nspluginwrapper/files/nspluginwrapper-i386-0.9.91.4-1.x86_64.rpm (Viewer)

(If the links above doesn’t work, then go to here)

Secondly, download latest Flash version from here and untar the file because we only need libflashplayer.so. Then …

# apt-get install ia32-libs ia32-libs-* alien linux32

Now we must use Alien to change the RPMs into debs because I use Debian (If you use other flavour of Linux different of Debian don’t do this because you probably will need RPMs)

# alien -d *.rpm

And then

# dpkg -i *.deb (* = Old RPMs changed into debs, so be carefull with paths and names)

We move libflashplayer.so to /usr/lib/mozilla/plugins (as root) and finally execute this:

# /usr/lib/nspluginwrapper/x86_64/linux/npconfig -i /usr/lib/mozilla/plugins/libflashplayer.so

or this one:

# nspluginwrapper -i /usr/lib/mozilla/plugins/libflashplayer.so

That’s all folks.

7 comentarios

  1. ¡¡Gracias tronco, me has salvado el culo!!

    ¡Un abrazo y muchisimas gracias!

    Alex.-


  2. Felicidades! es fácil y rápido.

    Gracias por tu ayuda!!

    Un abrazo


  3. muchas muchas gracias
    salu2 desde mexico


  4. He tenido problemas con aplicaciones flash, no me refiero a solo visualizarlo sino al interactuar con el, el flash se pierde (Deja de funcionar), sabes la razón?, o podrías ayudarme a solucionarlo?, gracias


  5. una vez que actualice las aplicaciones con el adept ya dejo de funciionar e hice todos los pasos de nuevo pero me arroja el error de

    *** NSPlugin Viewer *** preloader not found

    con la ult instruccion y no entiendo porque si ejecute los .deb movi el archivo libflashplayer.so a los plugins de mozila

    porfa una ayudita para orientarme… gracias,,,
    victoria


  6. No puedo instalar el adobe flash en ubuntu 8.10! ayudenme por favor, me parece que esto en linux es muy engorroso prefiero windows.


  7. Buenísimo, acabo de instalar debian 5.0.2 amd64 y lo necesitaba, GRACIAS!!!! 😀



Comments RSS

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: